Avatar

Using Postman to check API's first time

Tyler Moore

I have used postman before and haven't had this issue thus far but that doesn't mean I'm an expert. That being said I have went to my Kintone Admin site > System Administration>Integrations and created a OAuth Client called Postman Test. I have copied and pasted the info that was generated there and set allowed users. To my admin account for this kintone domain. I then, in postman, used the following GET URL : https://domain.kintone.com/k/v1/record.json?app=6 . and under authorization I selected OAuth 2.0 under Authorization tab. Then I selected Get New Access Token and input the data from Kintone into this area. Under token name I used the same thing I wrote in Kintone "Postman Test" , grant type: Authorization Code, Callback URL I used the redirect Endpoint URL (from kintone site), the auth URL I used the Authorization Endpoint URL, the Access Token URL I used the Token Endpoint URL, obviously the Client ID and Secret I did a direct copy and paste and that is it. When I select request token it came up and asked me for my username and password for Kintone which I used the allowed user account I set previously and then I get the following error on my results page :

{
    "code": "CB_JH01",
    "id": "4SPxH1RT01L3HPoXyM3q",
    "message": "Authentication failed. X-Requested-With header is required for session authentication."
}
 
Any help in getting moving forward would be much appreciated!
 
Tyler
Follow 2 followers
0

1 comment

Avatar
Yuzo Arai 0 votes
Hello Tyler,
 
I know that CB_JH01 occurs when you incorrectly defined the X-Requested-With in some way. However, from the given info, I'm not quite sure the actual cause.
 
I suppose you used the following Kintone article to set it up, but can you look at it again to see if there is an error in the settings?
 
If the problem persists, can you send me screenshots of the settings and the codes, if that's possible?
 
Best regards,
Chris
0
Comment actions Permalink